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Introductory civilcad 6 
 

(1-day course) 
 
 

Outline: 
 

This course is designed for new and relatively inexperienced civilcad 6 users. The course 
introduces the user to the main features of the civilcad 6 survey module, and provides the 
user with standard procedures to be followed when processing and plotting survey data. 

 

Method of Teaching: 
 

This is a “hands-on”  course with each participant using a computer to work through a 
series of exercises. These exercises are supplemented by training notes and a short quiz on 
each different topic. 

 

Expected Results: 
 

After attending this course, the participant would be expected to have: 

·  A sound understanding of the civilcad 6 functions and features 

·  An ability to set up a civilcad 6 library 

·  Skills required to create a digital terrain model and plot a detail plan 

 

Course Files: 
 

·  Park.GT7 
·  Survtut.XYZ 
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INTRODUCTION 
 

This training manual is designed to help first time users of civilcad 6 to get started with all 
of the features and functions of civilcad 6. It is intended that the manual be read as a 
supplement to the “ Introduction to civilcad 6”  training course. By the end of the course you 
should be able to Setup a civilcad 6 library, Setup survey codes for instrument downloads, 
Edit a digital terrain model including annotations and finally plot to a plotter. 

The following chapter will provide steps of how to open a new job and set up the default 
settings for all other jobs in civilcad 6.   

 

STARTING CIVILCAD 
 

Double click on the desktop icon or select civilcad 6 from the start button. 

When civilcad is opened for the first time the startup menu will be presented. 

This menu provides options for opening new or existing files and setting parameters of 
the program and printer. 

The options available from the Startup File menu are as follows: 

 

 File       View   Help 
  
 New Ctrl+N  Status Bar Help Topics 
 Open… Ctrl+O   - - - - - - - - - - 
                                                   About Civilcad 
 - - - - - - - - - -   - - - - - - - - - - 
 Program Setup…    Registration 
 - - - - - - - - - -     
 Print Setup… 
 - - - - - - - - - - 
 Previous Job 1 
 Previous Job 2 
 Previous Job 3 
 Previous Job 4 
 - - - - - - - - - - 
 Exit 

When opening civilcad for the first time it will be necessary to establish the Program 
Setup and the Pr int Setup. 

PROGRAM SETUP OPTION 
 

Select the Program Setup option.  A dialog box with six pages of options will be 
displayed on the screen.  Select the Tabs at the top of the page to change pages.  The 
settings established here are global and will become the default settings for any new files 
opened in the future.  These settings can be changed at a later time or can be changed on a 
local, file by file basis using Job Set-up, which will be available once a job is opened. 
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The settings that can be made here are as follows: 

 

·  User Information 

·  Directories 

·  Libraries 

·  Unit Settings 

·  Annotation Settings 

·  Preferences 

 

 The program setup dialog box is shown below: 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

EXERCISE 1 
 

1. Go to the User Information tab and fill out the required information 

2. Go to Director ies tab and confirm that the paths for your data and library 
directories are correct 

3. Go to the L ibrary tab and confirm that the file names are the same as those shown in 
the “civilcad 6 Library”  chapter 

4. Check Unit Settings and Preferences 

Figure  - Use the Program setup dialog box to define global settings for 
civilcad6 
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5. Click OK and go to File -> New 

PRINT SETUP 
 

When this option is selected the Print Setup dialog box will be displayed.  Select the 
default printer, paper size and orientation. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

SCREEN DISPLAY 
 

TOOLBARS 
 

The civilcad 6 survey module screen comprises of the 6 
toolbars detailed below. These toolbars can be individually 
turned on or off with the use of the option View -> 
Toolbar . When this option is selected the following dialog 
box will be displayed: 

Place a tick in the box if you wish the toolbar to be 
displayed. By default all of the toolbars will be on. 

These toolbars are designed to make commonly used 
options more accessible to the user without the need to 
browse through the pull down menus at the top of the 
screen. 

Toolbars can be placed anywhere on the screen. 

Figure  - Use the properties dialog box for more details 
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ADD ENTITY 

 
 
 

 

 

 

Used as a shortcut for the creation of most civilcad entities. The different types of 
entities used in civilcad are: 

 

 

 

 

 

 

 

 

To enquire any of these entities in civilcad 6, simply double click your left mouse button 
on the entity and a dialog box showing all information about the entity will appear. This 
information can be edited if the entity is unlocked. 

 
 
MODES 

 
 
 

Mode settings used when creating an entity. Includes snap modes and radiation modes. 

 

PROPERTIES 

 

 

 

 

 

 

 

  

·  Points ·  Str ings 

·  L ines ·  Polygons 

·  Arcs ·  Text 

·  Circles ·  Alignments 

·  Lots  

Create Point Add Line Circle 

String 

Polygon 

Add Text 

Current Layer  

Layer Settings Set Attributes 

Current Colour Code 

Current Symbol 

Line Style 

Figure - The properties toolbar displays the current attributes that will be applied to the next entity 
created. 
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Within the properties toolbar there are two controllers used to set the current attributes; 
Layers and Codes. By selecting a layer or code and then one of the Set Attributes (red 
arrow buttons), all of the attributes for that layer or code will be displayed in the Drop 
Down List Boxes. To view the settings for layers click on the Layer Settings button shown 
in the figure above. To view the survey code settings go to L ibrary -> Survey Codes. 

The primary controller for the attributes is the selected Survey Code and not the selected 
layer. This can be seen by first selecting a layer with known attributes and notice that no 
fields change until the Set attributes (right red arrow) is selected. Now if you select a 
Survey Code with known attributes, all fields will immediately change to those settings. At 
any point the individual attributes can be altered without affecting any others.  

 

 

STANDARD 

 

 

Screen display tools such as zoom options, redraw, regen and also file tools such as new 
job, save and print. 

 

SURVEY TOOLS 

 

 

 

TEXT 

 

 

Current attributes to be used for the next created text. 

 

 

SELECTION METHODS (for Global Editing) 
 

In civilcad 6 the simplest method of selecting an entity for editing is by double clicking 
your left mouse button on it. By doing this you will open one of the numerous “Edit…” 
dialog boxes available depending on which entity you have selected. This method of 
selection for global editing obviously has its limitations and is therefore supplemented by a 
number of other options in the Edit pull down menu of the Survey module. The most 
flexible option, of all of these, for global selection is Edit -> Select By…. When this 
option is selected the following dialog box will appear: 
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To use this option follow these steps: 

 

1. Go to Edit -> Select By… 

2. Select all layers contained in the selection 

3. Go to any or all of the entity tabs that will be included 

4. Place a tick in the Select .. checkbox like this: 

5. Select the criteria for the entity selection .Eg. 
Colour of points to be selected 

6. Repeat for all other entities 

7. Press OK 

 

There should now be a yellow box around the extents of the selection and the selected 
entities highlighted in yellow. This selection box is temporary and will disappear if the 
screen is refreshed. For this reason the global editing needs to be done next. 

 

GLOBAL EDITING 
 

While the yellow selection box is still displayed on the screen you can use either of two 
methods to enter the global editing option;  

·  Go to Edit -> Proper ties OR 

·  Right Click on screen and select properties 

 

By doing this the following dialog box will appear: 

 

 

Figure  - This dialog box will allow you to select any sub set of entities based on any 
attributes of those entities. 
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To use this option follow these steps: 

 

1. Select the Tab of the entity you wish to change the attributes of 

2. Place a tick in the checkbox (edit flag) beside the attribute you wish to edit   

3. Select what you want to change the attribute to from the Drop Down List Box 

4. Press OK 

 

In the case shown above, this would have the affect of changing all points within the 
selection to Green (Colour 2) 

 

MULTIPLE DOCUMENT INTERFACE 
 

Civilcad 6 allows the user to have open multiple jobs at the same time. This is made 
possible by the Windows platform that civilcad 6 is based on as opposed to the DOS 
platform that was used in civilcad 5.x. Most users should be familiar with this after using 
the basic Windows applications such as MS Word.  

 

The jobs that are currently open, can be viewed by clicking on Windows and looking at 
the job names listed at the bottom of the menu. By selecting one of these from the list, the 
job selected will become current on the screen and ready for editing.  

Figure - Use this dialog box to edit any 
attributes of any entity contained in the 

selection 

Edit Flag 
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In addition to changing between jobs, there is also the option to display all of the 
windows at the same time by either Tiling them (side by side) or Cascading them (current 
job shown in full and only title bar of other child windows displayed). The toolbars at the 
top of the screen will reflect the state of the current job and will change as you change 
between jobs.  

 

Another advantage of the Multiple Document Interface in civilcad 6 is the ability to view 
the same set of data from different viewpoints. To do this use the option Windows -> New 
Window. This will create a new window identical to the current window that can be 
navigated around independently of the original. One example of this would be to zoom 
extents within the original window and then zoom and pan in the New window. This will 
allow you to always have an eye on the overall job. Any editing will apply to both 
windows.  

 

HOT BUTTON 
 

The Hot Button (also referred to as the General Display Settings) is located in the middle 
of the Status bar at the bottom of the screen. The Hot button is the red icon shown here :  

 

 

 

This icon will be present in all of the modules within civicad, and will provide a 
different group of settings for each module.  

The settings contained in the Hot Button are generally for display only and are not for 
the creation of any entities. There is however, the option of issuing default point attributes 
to be used when new points are created in any option. These defaults will be shown in the 
prompt bar at the bottom of screen and can be altered during the option. 

 

 

LIST DATA 
 

This option provides a listing of selected entities with the attributes for those entities 
included. The file created is, by default, saved as a civilcad output file (* .rep), which can 
be opened with the text editor of your choice. The two most common text editors within 
the Windows operating systems are Notepad and Wordpad.  This file can be printed to 
your default printer and used as hard data.  

When this option is selected the following dialog box will appear: 

 

 

Hot Button 
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By default, all of the entities will be selected but with no point selection criteria. In the 
sample above, all points from point number 1 to 50 will be listed, as well as all lines, arcs, 
text and lots irrespective of point numbers attached. 

 

Figure - Use this selection filter to make 
your selection for the listed output file 
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INTRODUCTION 
 

Civilcad 6 uses a design library to store information that is available to all jobs. The 
library contained in civilcad 6 is more intuitive than in version 5 and is much more 
graphical. This means that Line Types and Symbols used in civilcad 6 can be viewed 
before selection. The library files are stored in a separate subdirectory called L ib and 
can be imported easily from version 5 installations.  

This chapter will detail the steps used to set up a civilcad 6 library 

The Library menu is shown below: 

 

 

 

 

 

 

 

 

 

IMPORTING THE LIBRARY 
 

The information in the library is obviously very important in an office environment 
and is transferable between computers. This makes it possible for all the computers in 
a department to be using an identical library. As explained in detail later on in the 
manual, the files containing information for the different libraries can be seen in the 
following table: 

 

L IBRARY FILE 

Survey Codes Svycodes.lcd 

Text Styles Textstyle.lts 

Symbols Symbol.lsy 

Line Styles Linestyle.lls 

Title Block (Title block name).tbk 

 

Figure - civilcad 6 Library menu 
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To import libraries from version 5 installations into civilcad 6 installations use the 
“ import”  option in the required libraries dialog box as shown below:  

(The example of importing Survey codes from civilcad 5 is used here) 

 

TITLE BLOCKS 
 

The “Print”  option cannot be run unless you have a title block. The following information 
outlines the steps necessary to create a title block. Civilcad title blocks should include a 
border and any title information required. You may wish to create all your title blocks in a 
separate job but this is not imperative.  

You should begin by drawing the border of the title block in millimetres using any Survey 
module options that are necessary. Secondly, create the line work for the title block 
information area, as shown below, and add required text. 

 

Most title blocks will have text strings, which will be unique for each plot such as 
name, date, etc. Using the option Inser t -> Keywords will allow you insert these 

variable text strings into your title block. Although the actual text string may not be known, 
the position will not change from job to job. If the text is not placed now you will have to 
create it in the correct position for each plot. You can save time by creating a text string in the 
correct position and saving it with the title block. When you plot a drawing using this title 

Figure  - By selecting import you will be able to browse to the Svycodes.lcd file in your civilcad 5 
data directory. 
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block you can plot it to the Drawing Editor and then edit the text string before sending to the 
plotter. The position does not need to be changed. 

When you have drawn the required title block, run the option L ibrary -> Title Block  

EXERCISE 1 
 

We will create an A1 title block with dimensions 790mm by 560mm with a title strip 50mm 
along the left and bottom edge of the title block. 

 

1. Create a new job named TITLE and make this the current job. From within the Survey 
Module, draw a title block with the following dimensions: 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Enter Keyword Text 

 

2. First select the option Inser t->Text and left click in the title area to position the text. 
Type SCALE. The actual scale of the plot window will follow this when you position the 
relevant keyword next. 

3. Now select Inser t->Keyword->Scale and select a position just to the right of the word 
SCALE. These 2 entries should now appear in the title block as follows: 

 

 

 

 

790mm 

56
0m

m
 

50mm Title Area 

Figure  - Select any position for the starting point 

A1 TITLE BLOCK 

Keyword 
Text 
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When this title block is used for plotting, the correct scale will appear at this position as 
shown below: 

 

 

 

 

 

 

 

 

 

 

Save the Title Block 

 

4. Select the option L ibrary->Title Block and fill out as shown here: 

 

The first two prompts, after pressing “OK”, allow you to define a window around the 
border of your title block .The second two prompts allow you to define the drawing area 
available for plotting. This should exclude the title strip.  

5. Give this title block a name and place it in the civilcad “Library”  directory. The file 
created will have the extension (.TBK) 

 

 

The cursor should be placed on the lower left hand corner of the title block border. 
Depending on the margins allocated in the previous step, this will dictate the distance from 
the bottom and left edges of the paper (different plotters/printers may have different results 
for this depending on the plotters origin) 

 

This title block will be used later for plotting. 

Drag margin 
corner to corner 

of border 

Keyword 

Figure - Keyword will be replaced by job specific 
information 
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CREATING SYMBOLS 
 

In civilcad 6, symbols can be created within the survey module or the symbols editor. 
Symbols can be either scalable or non-scalable. This is selected when defining the properties 
of the symbol using the option Edit -> Definition within the symbols editor. Prior to using 
this option you will need to set the insertion point using Edit -> Set Inser tion Point.  

·  A Non-scalable symbol will always plot at the same size regardless of plot scale 
and paper size. X and Y scale can still be applied to the symbol. If the symbol is 
created at a size of 3 units and X and Y scale are both 1 or 0, the symbol will plot 
at a size of 3mm.  

·  If a Scalable symbol is created, the plot scale will alter the symbol size to 
represent the true size of the feature. A scalable symbol can be created at any size 
but will plot at 2mm if X and Y scale are 1 or 0 and plot scale is 1:1000. This 
represents a 1m radius for a circle. An example of a scalable symbol would be for 
a tree. Look at the chapter “ Point Coding”  for details on applying a scale to a 
scalable symbol. If you create a symbol to represent a tree with a spread of 4m, it 
will be plotted at 4m according to the plot scale. 

 

EXERCISE 2 
 

Create two symbols:  

·  A triangle to represent a traverse station and  

·  A scalable tree.  

 

Traverse Station (Non-Scalable) 

1. Open the job called SYMBOLS and make this the current job.  

2. Draw a triangle with the side length 3 units.  

3. Use the Inser t->L ines option to create the following lines. 

 

 

 

 

 

 

4. Create insertion point using the options Cogo->Segment L ines/Arcs and Inser t-
>Point->Intersection 

 

Bear ing Distance 

90 3 

330 3 

210 3 
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The Symbol is now ready to save. 

 

5.  L ibrary->Define Symbol 

 

6. Select Edit -> Set Inser tion Point to define the position that the symbol will be 
placed in relation to the point. Click on the centre point. 

7. Now define the symbol using the option Edit->Definition and fill out using no clip 
boundary and not scalable. 

8. Go to File -> Save Symbol As and give it a name STATION 

 

This symbol is now a non-scalable symbol used to represent a traverse station. 

 

Tree (Scalable) 

 

We will now create a scalable symbol for a tree. There are many ways that a tree can be 
represented and you can experiment with the various drawing options to create the desired 
symbol. We will create the following tree symbol: 

 

 

 

 

 

 

 

 

1. Still in the same job SYMBOLS.CC6 draw one circle with a radius of 0.5 and another 
with a radius 5 using the same centre point. 

2. Segment the outer circle using the option Cogo->Segment L ines->10 equal par ts and 
select outer circle of radius 5. 

3. Go to Edit->Select By…-> Arcs->Select Arcs and press OK 

4. Press delete. This will delete all segmented arcs. 

5. Create 2-point arcs of radius 1 between all remaining points on outer circle. This 
should now leave you with the shape shown above.  

6. Drag a box around the new symbol and go to L ibrary->Define Symbol 
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7. Use the option Edit->Set Inser tion Point and left click at the centre points of the 
circles. This position will represent where the point in the survey module will be 
placed with respect to the symbol. 

 

8. Now define the symbol using the option Edit->Definition and fill out as shown below: 

 

 

 

 

 

 

 

 

 

 

 

 

 

9. To save this symbol go to File-> Save Symbol As and give it a symbol name. 

  

Upon entering the Survey module ensure that the Symbols are on in the red “Hot Button”  at 
the bottom of your screen. 

At this stage the symbols are only available to the job you are currently in. To save the new 
symbols to the civilcad library, do the following. 

10. View -> Symbols -> Select the Symbols using normal windows methods -> Save to 
L ibrary. These symbols will now be available for use in all other jobs. 

CREATING LINE TYPES 
 

Line Styles in civilcad 6 can be given any user definable name. This name can include 
alphanumeric characters and is therefore not restricted by printer/plotter-defined linetypes, as 
was the case in civilcad 5.  

Line style creation is carried out in the line style editor and is similar in process to symbol 
creation in the symbol editor. The main difference between the two is that line styles will not 
be scalable. When in the linestyles editor, the unit length and width of the linestyle will be the 
length and width of the linestyle in ground units once plotted. 

The following example will guide you through the creation of a simple linestyle for a fence 
and a linestyle for a power line and the application thereof.  

 

Figure - The insertion point was previously 
defined.  Only need to nominate clipping 
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EXERCISE 3 
 

We will create a new line type for a fence:  

 

Fence 

1. Go into the Line Styles editor using View->L ine Styles -> New 

2. Select Inser t-> L ine and ensure that Point radiation is set by using the icon shown here: 

 

 

 

 

3. Click any point on screen for your starting point. This will not effect the line style 
definition. 

4. Now draw a single line on a bearing of 90 degrees and distance of 7 units.   

5. Draw a diagonal line with your mouse approximately 2 units long at the end of the line 
as shown below: 

 

 

 

 

 

 

 

6. Set insertion point by Edit -> Set Inser tion Point and left click the start of your line 

7. Edit -> Definition 

8. File -> Save L inestyle As… 

At this stage the line style is only available to the job you are currently in. To save the 
new line style to the civilcad library, do the following. 

9. Go to the Survey Module 

10. View -> L ine Styles -> Select L ine Styles -> Save to L ibrary 

 

Approx. 2 units long 
 

Point Radiation 
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DISPLAYING SYMBOLS AND LINE TYPES 
 

1. Change back to the SURVEY module and go to File->New 

2. Turn on Point Symbols and Line styles in the Hot Button as shown below: 

 

 

 

 

 

 

 

 

 

 

 

 

3. Create a few points. Insert lines between some of these points 

4. Drag a selection box around these new points and lines and right click inside the box. 
Select Proper ties 

5. In the points tab select your new symbol with X and Y scale of 10 (shown below), and 
in the line tab select your new line type. Press OK 

 

 

 

 

 

 

 

 

 

Your new symbols and line should now be displayed on the screen. Now experiment with 
your other symbol and combinations of the two. 

 

 

 

Figure – Select the edit flag for symbol, Xscale and Yscale.  
Chose your new symbol and enter a scale of 10 for  X and Y 

Edit Flag 

Figure  - Turn the Point Symbols and 
Line Styles on in the " Hot Button"  

Hot Button
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SUMMARY 
 

When creating and using a civilcad 6 library for use in office environment the following 
considerations need to be taken into account: 

 

·  Import existing library from civilcad 5.x 

·  Creating new Title blocks, Symbols and Line styles  

·  Displaying and plotting of the Title Blocks, Symbols and Line styles 

 

Civilcad 6 allows great flexibility to import libraries from civilcad 5.x by way of an import 
button in the relevant libraries dialog box.  

When creating new symbols, use a Scalable symbol when the actual size of the feature is of 
importance, for example in the case of a tree, and a Non-Scalable symbol when the size of 
the symbol needs to remain constant when plotted on a plan. This would be so in the case of a 
survey mark on a Deposited Plan. 

To display Symbols and line styles use the Hot Button. 
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INTRODUCTION 
 

This chapter describes the use of point coding in civilcad 6. It includes information on 
the relevant options, special features in the coding system and an exercise on completing 
the relevant screens.  

 

In order to successfully transfer survey data from the field to civilcad 6 with the intended 
formats for all points and lines, the Survey Codes and Code Settings options should be 
completed before Reduction of survey data. When the Code Settings option is selected the 
following dialog box will appear: 

CODE SETTINGS 
 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

 

The “ Survey Code Settings”  dialog box has combined the version 5 options STR 
CTRL & CODE CTRL.  

 

Figure  - Complete the Survey Code Settings before reducing your 
survey data. Sections are detailed below. 

1

2

3
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1. SURVEY CODE FORMAT 
 

This option is used to specify the preferences for feature coding conventions in your 
department. This allows the civilcad 6 user great flexibility when reducing data sets from 
different surveyors using different conventions. The user can specify the following: 

 

·  The number of digits for the string part of the code 

·  The string number should prefix or suffix the code 

·  Store the contour flag (see later for explanation) 

·  The contour flag should prefix or suffix the code 

 

2. SURVEY CODE COMMANDS 
 

This option is used to set preferences for special survey codes. These codes will allow 
the user to set a character that performs a function to the data. When applied after the 
nominated delimiter these characters will perform the following functions: 

 

·  Start an Arc 

·  End an Arc 

·  Close a String 

·  Close a rectangle  

·  Scale a scalable symbol 

·  Provide check calculations to a known point 

 

3. OFFSETS 
 

The Offsets section of the dialog box contains the special characters that will be used to 
offset a point by designated distances in three directions. (See below for a detailed 
explanation) 
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SURVEY CODES  
(see dialog box in chapter 2) 

 

This option allows the user to assign specific attributes to their survey codes upon 
reduction into civilcad 6. The information is accessed during the data reduction and results 
in points being assigned such attributes as layer , line type and color . When due 
consideration is given to the setting up of the survey codes, it is possible to create complete 
and accurate topographical plans quickly and with minimal editing. 
 

 

Command codes should not be used when naming survey codes. This will result in 
points being shifted from their true positions, depending on the command code used. 

 
 
 

SURVEY CODING 
 

A survey or feature code is a group of characters assigned to observations taken by the 
surveyor in the field that is used to allocate a descriptive remark to each point. The main 
reasons for using these codes are as follows: 

 

·  To assign attributes to each point 

·  To control automatic stringing of line features such as fences 

·  To identify individual points 

 

The correct use of survey codes will enable considerable time saving in data reduction 
and plan preparation. The survey codes used in the field are used in conjunction with the 
civilcad 6 Survey Codes in the following ways: 

 

·  As an identification of a particular point 

·  As a control to determine if a point should be included in the DTM 
(Surface Model) or whether a line should be a breakline or not 

·  As a control to assign a point to a string 

·  As a control to assign a point into a designated layer 

 

The survey code consists of 5 parts as shown below: 

 

Control 
Characters 

Descriptive 
Characters 

Command 
Codes 

Offset 
Codes 

Comments 
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The nominated delimiter separates Descr iptive codes and Command codes and 
command codes will always follow descriptive codes.  

CONTROL CHARACTERS 
 

The control characters consist of a maximum of 3 characters for strings and 1 character 
for the contour flag. The contour flag is optional and the position of both the string and 
contour characters can be set to either prefix or suffix the descriptive part of the code.   

 
 

For example a code may be    0012TR10       Where: 

 

Example Code Descr iption 

001(Control) String Number – Maximum number of strings = 1000 

2(Control) Contour flag – 0 = Non Contourable, 1 = Contourable, 2 = Use 
Survey Codes 

TR10 
(Descr iptive) 

Descriptive part of the code 

 

The code could also be recorded as TR100012 depending on the settings in “Code 
Settings” . Note that no delimiting character is necessary between these two parts of the 
code. The settings in “Code Settings”  are used to determine how many characters are used 
for the string number and whether they prefix or suffix the descriptive part of the code. 

 

DESCRIPTIVE CHARACTERS 
 

For numerical data recording the survey code must contain the control part of the code. 
If none are required you should enter 000 or 0000 depending on the number of characters 
set for the string. The descriptive part of the code may contain up to seven characters. For 
example a code may be, 00101125333 where: 

 

Example Code Descr iption 

001(Control) String Number 

0(Control) Contour flag 

1125333(Descr iptive) Descriptive part of the code 
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For alpha- numerical data recording the control characters are optional and the code 
must contain at least one character. The descriptive part of the code may contain any 
number of characters up to 32 . E.g. valid codes would be: 

 

·  TREE 

·  01FCE 

·  0013ROAD 

 

 

COMMAND CODES 
 

Command codes are special codes used to close strings, form rectangles, and compute 
two and three point arcs. These are defined in Survey Code Commands section of the 
Survey Code Settings dialog box (see figure above). These codes must be recorded 
following the descriptive part of the code and separated from it by the specified delimiter. 
If the string characters are set to suffix the description they will also suffix the command 
codes. An example of a command code is AS to signify the start of an arc. It could be used 
as follows: 

 

·  02KERB*AS 

 

 

OFFSET CODES 
 

Often it will not be possible or desirable to observe the required point directly, but it will 
be possible to observe a point nearby and then measure an offset to the required point. E.g. 
coordinating the center of a tree. Civilcad provides a means for handling this problem with 
an additional code that can be recorded. There are three possible offsets that may be 
required. They are: 

 

·  Height         (H) 

·  Tangential   (T) 

·  Radial          (R) 

 

The method used is to record a decimal point followed by one of the three letters shown 
above (H, T, or R) and then a numerical value for the offset. The offset can be positive or 
negative with the sign being recorded only if negative  
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The positive sign must not be recorded as the character could also be used as a 
delimiter. 

 

These codes can also be combined so that you could for example record both a vertical 
and a tangential offset. The following diagram and examples illustrate the use of offset 
coding: 

 

 

CODE RESULT 

Code.T-
0.5R0.3 

This code would cause the reduced point to be 0.5 to the left of the line 
of sight and 0.3 on from the observed point. 

Code.H1.2T0.6  This code would cause the reduced point to be 1.2 above and 0.6 to the 
right of the observed point. 

  

 

Note in the above examples where a second offset is recorded it is not proceeded by a 
decimal point. 

 

 

COMMENTS 
 

Additional comments can be added to the code of a point. This may be for example a 
description of a tree species or size. These comments should be recorded following the 
descriptive part of the code and separated from it by the specified delimiter. These 

Code.H0.5 

Code.R0.5 

Code.H-0.5 

Code.T0.5 

Code.T-0.5 

Code.R-0.5 

Figure  - Possible Offset codes used to shift the measured postion of a point if required 
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comments are not used by the program in any way but they are for the users benefit in 
creating the model. For example the following code may be assigned to a point. 

 

                    01FCE/1.5H*c where: 

 

Example Code Descr iption 

01(Control) String Number  

FCE (Descr iptive) Description 

/ Comments Delimiter 

1.5H(Comment) Comment showing the fence is 1.5m high. 

*  Command code delimiter 

C (Command) Command code used to close the string back to the first point 

 

 

POINTS TO NOTE 
 

(I) The control digits override information in the “Survey Codes”  screen E.g. In the 
Survey Codes screen a code “FENCE” is classified as a point feature and set contourable. 
If points are coded 010FENCE during reduction the points will be strung and made non- 
contourable due to the 0 contour flag. 

 

(ii) It is not essential if using an alphanumerical data recorder to record the control 
characters. If they are not recorded, points will be strung or contoured according to the 
setting in the Survey Codes screen. 

 

(iii) For a numerical data recorder it is essential to record the control characters.  

 

(iv) When using the control digits for stringing, the descriptive part of the code is also 
taken into account i.e. points with the code 001TB will not be joined to points coded 
001BB. Therefore the user may have 999 strings per code if 3 digits for strings control is 
assigned. 
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Although the above notes on feature coding specifically apply to total stations, the same 
type of coding may be entered in the code column in the data entry screens and on 
reduction the point will be controlled either by the control characters of the code and/ or 
the Survey Code information. Refer to the diagram above for examples of feature coding. 
Note that you may pick up a point on string 1, followed by a point on string 3, etc, however 
you must pick up points on the same string in the correct sequence. 

EXERCISE 1 
 

In this exercise we will look at how Survey Codes and Code settings are set up and 
edited. 

1. Create a new job called SURVTUT and make it the current job. 

2. Ensure that the option L ibrary->Code Settings are set to default values as can be seen 
at the beginning of this chapter. 

3. Select L ibrary->Survey Codes.  

4. Double click on any of the codes displayed and the attributes can be easily altered here. 
Alternatively, select the code and press Modify. 

5. Select the Code TR and change the symbol to your new symbol created in chapter 2. 

6. Select the code F and change the line type to your new line type. 

7. Select the code STN and change the symbol to your new symbol 

 

This will now allocate these new objects to your codes on reduction of a neutral file 
shown in the next chapter. 

Figure  - Examples of codes that would be used when stringing fence lines and roads and also 
scaling trees 
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SUMMARY 
 

1. The use of the options Code Settings and Survey Codes from the library menu allows 
considerable time saving in data reduction and plan preparation. In the Code Settings 
dialog box there are three main areas for consideration: 

 

·  Survey Code Format 

·  Survey Code Commands 

·  Offset Codes 

 

2. You should ensure that these dialog boxes have been correctly completed before any 
data reduction is done. 

 

3. The point coding used in the field can consist of five parts: 

 

·  Control characters 

·  Descr iptive characters 

·  Command codes 

·  Offset codes  

·  Comments 

 

4. The control characters override information in the Survey Codes screen. 

5. For an alphanumerical data recorder it is essential to record the control characters. 

6. An assigned delimiter will be required to separate the descriptive characters from the 
command codes. 
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Chapter 4 

 

 

 

 

 

 
 

Data Entry and Reduction 
 

 



civilcad 6 Training Manual - Introduction       

39  15/04/2004 

INTRODUCTION 
 

Civilcad 6 offers several methods of entering survey data. The options available include 
total station reduction, manual entry, loading a file of co-ordinates, and direct entry using 
the drawing functions available in the Survey Module. Data entry functions available that 
will utilize the point codes are as follows: 

 

·  Neutral Editor  

·  Point Entry 

·  Traverse Editor  

 

When using the options Level Book Entry and direct entry into the survey module, the 
Survey Codes screen will not be used. 

 

TOTAL STATION DATA 
 

Downloading, translating (to a neutral file) and reducing (a neutral file) from a Total 
Station can be done entirely from the Neutral Editor  in version 6. Civilcad 6 converts raw 
downloaded files from any supported data recorder into a neutral format. The neutral file 
can be edited to correct any errors. Use the option File-> Save to Survey to transfer the 
reduced data from the neutral editor to the survey module of civilcad 6. 

 

IMPORTING DATA INTO THE 
NEUTRAL EDITOR 
 

There are 3 import options available in 
the neutral editor as follows: 

·  Download Raw Data… 

·  Import Raw Data File… 

·  Import Neutral File… 

 

When any of these options are used, 
the data that is imported will 
automatically be translated to a neutral 
file format and reduced. This will display 
the job in the graphics view to the right 
of the neutral file ready for editing. The 
neutral editor is shown below: 

Figure  - When you select the option 
"Download Raw Data" all port parameters 

will be available for set-up 
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DOWNLOAD RAW DATA... 
 

 

 

 

This option transfers the raw data from the data recorder to the computer. The option can 
be found at File -> Download Raw Data… 

 

It is important to ensure that the communication settings on the data recorder should 
match those set in the Civilcad 6.2 download parameters. 

 

Topcon FC series data recorders must be downloaded in COMPUTER format 
rather than PRINTER format. The FC5 model contains communication parameters in 
two separate areas, which must both match the computer settings. 

  

 
 

Figure  - Neutral Editor Showing neutral file and reduced job 

Neutral Editor  

FILE Download Raw Data… 
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FLOW CONTROL (PROTOCOL) 
 

Protocol sets the manner in which data is transferred between data recorder and 
computer. The choices available are: 

 

None    no protocol is used to control data transfer. The transmitter sends the information 
without interruption. The receiver cannot send any signal to indicate that its buffer is full. 
Data may be lost using this method. 

 

Hardware    This is an industry standard protocol where the receiver controls 
transmission of data by sending electrical signals to the transmitter via specified pins in the 
connection. This requires a multi pin connection. 

 

XON/XOFF    This is an industry standard protocol where the receiver controls 
transmission of data by sending specified byte characters to the transmitter. This only 
requires a 2-pin connection and is a higher level of communication than hardware Protocol.  

 

 

IMPORT RAW DATA FILE… 
 

 

 

 

This option is used when raw data has been downloaded successfully and a raw file 
created. The option can be found at File -> Import Raw Data file… .By using this option 
the raw data will be translated into a neutral file and reduced to the graphics screen. The 
neutral file can be edited to correct any errors before reduction. 

 

REGENERATE VIEW 
 

 

 

 

When the neutral file has been edited, the option that is used to re-reduce the 
observations is View->Regenerate View. This will update the Neutral File Reduction 
Report, which is permanently open while the neutral editor is open.  

 

To view the Neutral File Reduction Report, go to the Window menu and select it 

Neutral Editor  

FILE Impor t Raw Data File… 

Neutral Editor  

VIEW Regenerate View 
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from the available items on the list. 

  

EXERCISE. 1 
 

This exercise will show how to convert a raw data file downloaded from a Topcon 
GTS700 Total Station into the neutral format and then reduce it into Civilcad 6. 

 

1. Create a new job called Park and make it current. We will assume that we have just 
downloaded the data file from the Topcon GTS700. An extract of the raw data file 
PARK.GT7 is shown below: 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

2. Go to the option View-> Neutral Files and select New to enter the Neutral Editor .  

 

3. Select File-> Import Raw Data File…. Complete the dialog box as shown below: 

 

Figure  - Caption of raw file in FC6 format 
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4. Press OK and browse to the downloaded file Park.GT7. For this course the file should 
be in the C:\Civilcad 6\Data directory. Once you have found this file select it and press 
OK. 

 

The program will convert PARK.GT7 file into PARK.NEU (Neutral file). An extract of 
the neutral file is shown below. The Neutral file format will be the same for all data 
recorder types. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

5. You will be prompted to enter coordinates for any control points (STN data) which do 
not have coordinates stored in the file (Park.cc6) or which can not be calculated from 
observations. In this case you will not be prompted for coordinates of station number 100 
as these have already been input as shown above. 

Figure  - Extract of the PARK.NEU neutral file 

Station 
Coordinates 

Figure  - Select the type of data recorder from the list 



 

44  15/04/2004 

 

6. To view any undefined codes go to Window -> Neutral File Reduction Report and 
scroll to the end of the file. If there do exist undefined codes these points will be imported 
to the survey module of civilcad 6 and placed in a layer with the same name as the code for 
the point. For example if a point has been observed with the code “NAIL”  and this is not 
in the survey codes, the layer “ NAIL”  will be created and this point will be placed in that 
layer. 

7. Have a quick look at the reduction information found in this report and confirm it is as 
expected. 

 

The neutral file Reduction report is linked to the neutral editor and therefore cannot 
be closed or edited. This is to ensure integrity between the reduced data and the neutral 

data.  

If you find that there are codes in the data set that are not defined in the Survey Code 
library, simply add the new code into the library, go to the Neutral editor and regenerate 

the view (reduce the data), and then re-save to survey. This will not duplicate what has 
already been saved to the survey module but will replace it with the updated attributes. 

 

8. Before transferring the reduced data to the Survey Module look at the graphics 
roduced during the reduction and check for orientation errors and other obvious faults. 

9. Now select File -> Save to Survey. This will open the reduced job into the Survey 
view ready for editing which will be covered later in the course. Before the job is 
transferred to the Survey module, the following dialog box will appear: 

 

 

 

 

 

 

 

 

 

 

 

When data is reduced, the symbols, linetypes, text styles and justifications required will 
be imported from the library into the job (so that when a job is transported these items go 
with it without the need to send library files). Any other of these items required in the job 
may be created new (and saved to the library if necessary) or imported from the library. All 
such local items will be shown in blue in the drop-down lists & un-used library items in 
black. 

Description contained in 
the Survey Code Library 

Strip the string control 
off the feature code 

Figure  - Selecting the feature code with "Strip Code" a code of 01Path will 
become Path 
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MANUAL ENTRY 
 

Manual entry in civilcad 5.x provides several options, however, many of the fields in the 
dialog boxes for these options are common to each other and can also be accomplished 
with the use of the neutral editor. Civilcad 6 has removed some of these redundancies and 
allows for 4 methods of manual entry: 

 

·  Point Entry 

·  Traverse Editor  

·  Level Book 

POINT ENTRY 
 

 

 

 

This option is used to input data that is already in coordinate format. This can be useful 
when reducing data with known control station coordinates. In this case coordinate 
information does not need to be entered in the field or at the reduction stage in the neutral 
editor. When using this option the following dialog box will appear: 

 

 

Figure  - Use the “point coordinate entry”  dialog box to enter survey control points for data reduction. 

Survey 

Manual Entry POINT ENTRY 

Warning: If you key in point numbers, which have already been used in the job, the 
old coordinates will be overwritten. You should assign numbers that have not been 
used or leave the number field blank and allow the program to assign un-used 
numbers. 
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TRAVERSE EDITOR 
 

This option is used for the manual entry of traverse data and will not be detailed in this 
course. 

 

LEVEL BOOK ENTRY 
 

 

 

 

This option allows the user to input leveling information in the form of cross sections 
and would normally be used for road design purposes. The option allows for the input of 
raw level book information in the format of Backsight, Intermediate and Foresight 
observations. There are also areas to fill in chainage, offset and reduced level information. 
When reducing this data, a road alignment will need to be selected to allow entry into the 
Roads module for creation of a design surface.  

  

If you do decide to enter the codes, you only have to enter a code when the code changes 
i.e. if you leave the code field blank the associated point will be assigned the code from the 
field above. 

 

EXERCISE 2 
 
In this exercise we will import an XYZ file named SURVTUT.XYZ which has the following 
format: 
 

 
  

Survey 

Manual Entry LEVEL BOOK 

Figure  - XYZ file format with Point Number, E, N, RL and Code comma delimited 
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1. Create a job name SURVTUT and make it current 
2. Make sure that Code Settings and Survey codes are as they were in Chapter 3 
3. Go to File->Import and select “File of Type”  XYZ file (* .xyz) 
4. Browse to the file Survey.XYZ which should be in the data directory. 

 

This option will load and reduce any file containing Point Number, Easting, Northing, 
Height and Code in that order. The column spacing is not important so long as the different 
types of information are separated by commas or spaces. 

 

The file will be loaded and reduced according to the parameters specified in the Survey 
Codes and should be almost complete. Later you will need to do some editing to finalize the 
model. This will be done in the next chapter. 

 
5. Look at the trees and fence lines to make sure that your own symbols and line types have 

been used. 
6. The example shows the use of double coding. The point coded 01F*C*02F is the last 

point on the first fence string, and the code C is used to close the string back to the first 
point in the string. The same point is also a starting point for a separate fence string, 
which is shown by the code 02F. 

 
The following extracts show examples of computing a three-point arc. The figure below 
illustrates these examples. In the case of a three point arc, the point preceding the point coded 
AE is used as the second point, and any other point recorded between AS and AE are ignored 
in the computation of the arc.  
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Chapter 5 

 

 

 

 

 

 

Editing the Model 
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INTRODUCTION 
 
 

This chapter describes how to edit a digital terrain model and set up contours for plotting. 
At this stage it is assumed that the topographical information has been downloaded and 
imported successfully into the current job.   

OVERVIEW 
 

Civilcad 6 contour plotting features enable you to interpolate and plot contours from a 
terrain model quickly and accurately. The relevant options would normally be used in the 
sequence shown below: 

 

Table 1 - Options used when editing the Model 

 
OPTION DESCRIPTION 

Edit the L inework Use Global Editing techniques to edit the model  

Create the Model Survey->DTM->Create DTM 

Delete the Long Tr iangles Survey->DTM->Delete Long Tri 

Delete Individual tr iangles Survey->DTM->Delete 1 Triangle 

Inser ting the Breaklines Survey->DTM->Insert Breakline 

Plotting the Contours Survey->DTM->Settings 

 

This chapter provides a rough guide to completing a Digital Terrain Model and assumes 
the user has some knowledge of the outcome required. 

EDITING THE LINEWORK 
 

Once you have reduced the network successfully into the survey module of civilcad 6 you 
may need to make some changes to certain aspects of the model that were overlooked during 
survey. These changes may include the addition of single lines to string un-strung points or 
global edits to make changes to an entire selection. Before making the changes carry out the 
following steps:  

 

1. Check the model and edit linework as necessary. At this point you should ensure that the 
features displayed are correct. I.e. 

·  Are the strings joined to the correct points?  

·  Are there any strings or points missing? 

·  Is any global editing required? 
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2. Before adding any lines or points ensure that the correct attributes are current for the 
layer. To do this, select the “Code” from the properties toolbar. All attributes should change 
to match those found in the code settings. 

3. It may be necessary to check the neutral file and perhaps make any corrections that are 
necessary before reducing the file again.  

4. If it is found that the parameters associated with a particular code need to be changed 
(Eg. you may wish to assign a different colour or layer to a particular code), you can edit the 
information in Survey Codes, enter the neutral editor and use the option View->Regenerate 
View. This option will re-reduce the data set according to the new information in Survey 
Codes. Save this new reduced data to the survey module and the strings will be updated 
without duplication of points and strings. 

 

CREATING THE MODEL 
 

 

 

This option creates a triangular mesh for the contourable points in the database. For a point 
to be contourable it must have a height and have the contourable flag set to ON within the 
points’  properties. 

 

The user should then view and check the triangular mesh for any long, thin triangles around 
the edges of the model. The hot button can be used to turn on both the display of the 
triangular mesh and contours. This can also be achieved using the option Survey->DTM-
>Settings. It is common to have these long, thin triangles around the edges of the model and 
the user should delete these to give a more accurate representation of the contours. If the 
contours are displayed you will notice that they are distorted across the long triangles because 
the heights are interpolated between points that are much further apart than the average. 

 

At this stage you need not be concerned with distorted contours other than at the edge of the 
model because break lines have not been inserted and they will affect the shape of the 
contours. 

DELETING THE LONG TRIANGLES  
 

 

 

 

 

This option is used to delete triangles whose length is greater than a nominated distance. 
Triangles of length below the nominated distance will be retained, and those longer than the 
distance will be deleted. You must then decide on a suitable distance to use. To do this, locate 

SURVEY 

DTM Create DTM 

SURVEY 

Delete Tr iangle by Side Length 
 

DTM 

DELETE 
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the largest triangle side within the model that you need to retain and use the option Cogo-
>Bear ing/Distance to enquire the length. This will now become your nominate maximum 
length.  

This option should delete most, if not all of the bad triangles in the model and it is then up 
to you to delete single triangles manually. 

 

DELETING INDIVIDUAL TRIANGLES 
 

 

 

 

The normal procedure is to look for any remaining distortions to the contours, zooming in if 
necessary, and deleting the relevant triangles by selecting the centroid point, which is shown 
by a green dot. If you delete the wrong triangle you can recreate by selecting the undo icon  

 

INSERTING THE BREAKLINES 
 

 

 

 

This option can be executed when creating the contours for the first time or separately once 
triangles have been edited. 

Breaklines are lines of discontinuity in the model surface such as top and bottom of banks, 
kerb lines, creek banks etc. For an accurate model, triangles should not cross these breaklines. 
For a line to be a breakline its end points must be contourable and the breakline flag for the 
line must be set to ON within the lines’  properties. 

SURVEY 

Delete 1 Tr iangle 
 

DTM 

DELETE 

SURVEY 

DTM Inser t Breakline 

 
Before Breakline insertion After breakline insertion 
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The above option will modify triangles that cross breaklines, sub-dividing them such that 
the new triangles formed will have sides lying along the breakline. This means that contours 
can be interpolated along the breakline giving a more accurate model. Refer to the figure 
below. 

 

In civilcad 6 the “ Insert Breaklines”  flag defaults to being on. This will mean that if 
you don’ t want to include breaklines you will need to un-tick this box. 

 

Alternatively, when creating the DTM (Survey->DTM->Create DTM), make sure 
that there is a tick in the check box for “ Insert breakline”  as shown: 

 

 

 

 

 

 

 

 

The user should again check the model for any errors and make corrections as necessary.  

 

  

 PLOTTING THE CONTOURS 
 

 

 

 

Finally, to assign major and minor contours, go to the DTM settings dialog box and double 
click on the required DTM.  

When contour intervals are assigned here, they will be applied when the plot is exported to 
the drawing editor. The Drawing editor will be detailed later in this manual. 

When this option is selected the following dialog box will appear: 

 

SURVEY 

DTM Settings 

Figure  - Ensure that Insert breaklines is ticked when creating the 
DTM 
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Figure  - Assign contour intervals for plotting using this dialog box 
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EXERCISE 1 
 

The aim of this exercise is to enable the user to become familiar with civilcads© triangulation 
and contouring facilities. Ensure that the current job is SURVTUT. 

·  The first step in this exercise is to check the data for correctness, and accuracy. In this 
case there is line missing for the fence, which you must create manually. This line should 
be created with the same attributes as the other fence lines and the best way to do this is to 
select the code “ F”  from the properties toolbar. This will immediately update the 
properties toolbar to make current all of the attributes for that code as set out in the 
“Survey Codes”  table. These can be changed individually after the code has been selected 
To create a line between the end point of one fence and the corner of the other fence, 
simply go to Inser t->L ine->Traverse. 

 

·  You may also notice that that the old tree symbol is being used if the survey codes were 
not altered in chapter 3. If this is the case change it to use your new symbol created 
earlier: 

 

1. Go to Edit->Select By…. -> leave all layers active->Select points by code TR 

2. Edit->Properties->” Points”  tab and change the symbol to “TREE1” 

3. Press OK and look at the changes made to the job.  

 

·  This should have had the effect of changing all trees to use the new symbol created 
earlier. 

 

·  Triangulate the job using the option Survey->DTM->Create DTM.  

 

·  You should now edit the triangles as described earlier. You will find long triangles along 
almost every side of the job and these should be deleted using the option Survey->DTM-
>Delete tr iangle by Side Length using a distance of approximately 45. You should then 
zoom in on a section of the boundary and with contours and triangles displayed, use the 
option Survey->DTM->Delete One Tr iangle to delete individual triangles around the 
edges of the job. You can use the PAN option to move around the boundary. 

 

·  When the long triangles have been deleted you can insert the breaklines lines using 
Survey->DTM-> Inser t breakline or  Inser t Batch breaklines. Alternatively you could 
have inserted these upon creation of the DTM. In this job there is an embankment in the 
North Eastern corner of the job. Refer to the figure below to see the effect of the contours 
before and after breakline insertion: 
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·  Often you will have areas of a job for which you do not wish contours to be shown such 
as on the inside of a building. To stop contours entering a particular area of the job, you 
will need to create a Boundary using the option Survey -> Volumes -> Create Boundary 
and place a tick in the Clipping Boundary text box. In our job there are two main 
buildings for which you can create a clipping boundary in this manner. 

 

·  You can experiment with the display of the contours using the options available in 
Survey->DTM->DTM Settings. Try changing the contour interval to get a desirable 
interval for plotting.  

·  You should now have the model triangulated and the contour settings required for 
plotting. The next step is to annotate the job with some text. Save the job by using the 
option File->Save. 

 

Figure  - Contours along a bank before and after breakline insertion 
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SUMMARY 
 

This chapter has explained the steps involved in editing a job from the reduced data stage to 
give a three dimensional, digital terrain model that will enable a plot of contours and other 
detail. 

 

The main steps involved are: 

·  Edit line work  

·  Triangulate the job 

·  Delete the Long Triangles 

·  Insert the breaklines  

·  Assign contour intervals for plotting
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Chapter 6 

 

 

 

 

 

Text 
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INTRODUCTION 
 

This chapter describes the use of the various text options in civilcad 6.  There are many 
different ways of inserting and storing text in civilcad 6 for different types of entities. Text 
can be stored either as Text or Annotation. The main difference between the two is that 
annotation is linked to the entity and text is independent of it. This is illustrated when moving 
a point with annotation attached to it. Notice that annotation will follow the point whereas text 
will remain in its original position.  

 

TEXT ATTRIBUTES 
 

As a general rule, the appearance of annotations will be controlled by the Settings-
>Annotation Settings option of the survey module. The annotation settings dialog box also 
controls some special text, such as bearing and distance, angle and point height. 

All text and annotations in civilcad 6 are defined by a Text Style, Or ientation and 
Position. Each of these will be detailed below. 

This chapter will take you through a series of short exercises with brief explanations 
covering the most common methods of inserting text into a job. 

Text Style 
 

 

 

The text style can be both created and stored in the job or the library, which will enable its 
use with other civilcad jobs. The text style will include Name, Font, Size, Colour and Style 
and can be created using the following dialog box: 

 

 

 

 

 

 

 

 

 

 

 

 

SETTINGS TEXT STYLES 

Figure  - This dialog box can be found in the option Inser t-
>Text Styles and select “New” 
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Orientation 
 

The orientation of the text is provided by the user when the text is being inserted. The 
value that is entered here is a bearing of the line defined by the start and end points of the 
text.  This value defaults to 90 which will create the text horizontally across the page. 

Position 
 

The position of the text is entered when the text is created and is referred to as 
“ Insertion”  in civilcad 6. The insertion field in the “ Insert Text”  option provides 9 different 
justification positions for a block of text. Any one of these can be selected by clicking on 
the required button. See below for use of this option. 

The nine buttons provided by civilcad, represent where the insertion point will be in 
relation to the added text. An example of the use of this option is shown below. 

The insertion position of the will be different for different types of annotation and the 
selected placement of it (eg bearing & distance placed centrally on a line and above or 
below the line), and if changed may upset the positioning of annotation when a plot is 
made at a different scale 

INSERT TEXT 
 

 

 

 

This is the most basic of the text creation options and is used to add a single text entry to a 
single insertion point. The text entry can be any number of lines long, in the form of a block 
of text.  

Click the mouse on the screen to position the cursor where the text is required and type the 
text; if necessary, adjust the location, orientation and insertion position on the prompt line. 
Press Enter to save the text, or right-click mouse & select "Accept text” . 

If you wish to create more than one line of text for a single text entry, press the Shift &  
Enter  keys together when you get to the end of each line of text. Shift + Enter keeps the 
cursor in the same position & shoves the text UP, but Ctrl + Enter moves the cursor DOWN 
one line and starts a new string. 

When this option is used to insert a single string of text, the attributes for the text will be 
those that are current on the screen. These are found in the text toolbar, which is shown 
below: 

 

 

  

TEXT STYLE FONT CHARACTER HEIGHT 

Figure  - Text toolbar showing the current text attributes 

INSERT 

TEXT TEXT 
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When this option is selected the prompt line in civilcad will appear as follows: 

  

 

 

  

 

 

 

 

 

 

 

 

If you wish to create more than one line of text for a single text entry, press the Shift &  
Enter  keys together when you get to the end of each line of text. This will retain the insertion 
point for that block of text and add the next text below the previous. 

Once the text has been created, the user can select the text by simply double clicking on 
it. The “Edit Text”  dialog box will appear as follows: 

 

 

 

 

 

 

 

 

 

 

 
Figure  - All of the properties of the text can be edited using this dialog 

box 

Figure  - To insert text you are required to provide an insertion 
point, orientation and justification 

Prompt 
Line 

Text Justification 
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CREATE ANNOTATION 
 

Most of the text that is created in civilcad 6 is firstly created as Annotation. Annotation is a 
flexible method of creating text and uses the “Annotation settings”  dialog box to control the 
appearance. 

Annotation can be generated for the following entities: 

·  Points 

·  Lines 

·  Arcs 

·  Dimensions 

·  Angles 

·  Lot Details 

 

To turn the annotations on and off use the annotation section of the general settings display 
tab found in the hot button. In order for the annotations to be displayed for a particular entity, 
the annotation flag must be ticked within that entities’  properties. An example of this is the 
annotation flags found in the “Edit Point”  dialog box shown here: 

 

 
 

 

 

 

 

 

As was the case with text, annotation is also defined by a text Style, position and rotation. 
In addition to these, there are also annotation tables, which are specific to the type of 
annotation being created. Annotation tables will contain settings that control the positioning 
of the annotation and may refer to other tables for such things as text styles.  

An example of this would be in the case of the “L ine Annotation Settings” . This table 
controls the positioning of the bearing and distance annotation of a line but refers to the 
“Distance Annotation Table”  and “Bear ing Annotation Table”  for line styles of each.  All 
tables are contained within the Annotation Settings dialog box shown below: 

 

 

 

 

Figure  - Annotation flags found in the 
"Edit Point" dialog box 



civilcad 6 Training Manual - Introduction      

63  4/15/2004 

 

 

SPECIFIC TEXT 
 

Specific text is any text that was created by options other than Inser t->Text->Text. This 
includes Annotation, Angle, Height, Co Ords etc. Specific text differs from other text in that 
the program derives the text string from information in the database. Such text is controlled 
by a text table as well as a specific text type table. 

Text such as bearings and distances of lines can be created using the option Inser t->Text-
>Bear ing and Distance. This option allows you to select a line to be automatically annotated 
with your choice of bearing and distance in various position combinations. The advantage of 
this option is that you do not need to know the actual text string as the program will calculate 
it for you, all you need to do is select the line to be annotated and a format for annotation. The 
result will be text and not annotation.  

Other specific texts such as angles, heights, coordinates and arc attributes can also be 
created automatically using the relevant specific text options. 

 

 

Figure  - Annotation is controlled by the “Annotation Settings”  dialog box in conjunction with the 
"Text Styles”  dialog box 
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LOT ANNOTATION  
 

 

 

 

Civilcad 6 includes a separate method of annotating subdivision lots. By selecting the lots 
and applying the option “Annotate Lots” , all lot details will be created based on the lot 
annotation table shown below: 

 

 

 

This table is used to specify the position and text styles for all available lot annotation 
types. To apply this table to your lot annotations, use the option “Annotate Lots” . 

 

 

PLOTTING TEXT  
 

The Proposed Scale setting in the hot button affects the appearance of all text, line styles 
and non-scalable symbols on screen. This field should be set to the proposed plotting scale 
and text size will be displayed in relation to the job for the proposed scale. If the job is plotted 
at a different scale, the plotted text will not be as it appears on the screen. 

 

If you wish to plot the same job at two or more scales it is possible that the text size used at 
one scale will not be suitable for another scale. In this case it is necessary to edit the text. It 
may be advisable if you create several text styles where the only variable is the character 
heights to suit the different scales that you commonly use. 

SURVEY 

SUBDIVISION Annotate Lots 

Figure - Lot annotations are controlled by the Lot annotation settings table found in the settings menu 
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EXERCISE 1 
 

 

In this exercise we will annotate the imported job SURVTUT with some Annotation and 
Text. The annotations that we will add are L ine Annotation for the fence line and  

 

1. Make sure that the job SURVTUT is open and currently displayed on screen 

2. Ensure that the fence is using the line-style created in chapter 2 (Turn on linestyles in the 
hot button) 

3. Go to Settings->Text Style-> Select BEARING ->Modify. This will be the text style to 
be used for the bearing part of your line annotation. Modify this to give it some colour and 
any other changes you want. 

4. Press OK 

5. Select DISTANCE and make necessary modifications 

6. Go to Settings->Annotation Settings->Distance Annotation Settings. Ensure name is 
$$DEFAULT and text style is DISTANCE 

7. Go to Bear ing Annotation Settings. Ensure name is $$DEFAULT and text style is 
BEARING 

8. Now go to Line Annotation Settings and ensure that Bear ing Table and Distance table 
are correct. 

 

These settings will be used when line annotation is created for the fence line 

 

We will now select the fence line by selecting all entities with the line type that we 
created earlier.   

 

9. Go to Edit->Select By…-> Layer  (FENCE)-> L ines ->Select L ines->Style (Select 
fence line style) 

This should produce a yellow box around the extents of the selection and the lines 
should be highlighted in yellow.  

 

10. Right click inside the yellow box and select 
Proper ties  

11. Fill out L ine screen as shown here: 

12. Press OK 

13. Go to The Hot button and turn on Line Bear ings 
and L ine Lengths in the annotations 
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14. Now experiment with the following tasks (instructor guidance may be needed): 

·  Add text to buildings 

·  Create new text styles 

·  Change text styles for the fence annotations and recreate  

·  Create Point annotation 

·  Create Lot annotation 

 

 

 

 

 


